灌水区
-
wordpress使用QQ邮箱为网站发送邮件
只需一个QQ号便有一个简单方便的邮箱服务器, 设置步骤 QQ邮箱中开启MAP/SMTP服务, 获取SMTP 密码,也就是授权码 安装wordpress 插件 WP Mail SMTP 填写插件需要的配置后,发送一篇测试邮件,成功发送则代表配置成功 具体步骤 登陆QQ邮箱 找到并开启 IMAP / SMTP 服务 开启完成之后得到授权码。值得一提的是现在开启需要自己发一条短信 &… -
宝塔云端“崩了13小时”复盘:你以为是面板故障,其实是云端依赖失效(附补偿领取攻略)
2026 年 1 月 7 日,宝塔官网及部分云端服务因机房突发网络故障出现异常,影响到官网登录、注册、购买、续费,以及面板部分云端能力。官方披露的恢复窗口从 06:10 到 19:10,持续约 13 小时。 这波对“面板=运维入口”的用户来说,体感就是:授权绑不上、账号登不进、续费买不了,业务操作链路直接断。许多站长发现虽然云端功能受影响,但本地安装的宝塔面板和 网站业务仍在正常运行 官方公告把关… -
Truncate 清空多个表
Truncate 不支持Truncate table1,table2...正确清空多个表的姿势是Truncate table1;Truncate table2;Truncate table3;分号不能缺, -
WordPress用户枚举漏洞修复加固
背景 wordpress建站系统,客户收到网警安全整改邮件 突然收到了网警的安全整改邮件,心里一下子慌了——自己的网站没乱搞,甚至还没开始运营,怎么就触发安全隐患了 让客户把邮件转发一看,确实有这个问题,并且经过我验证,测试了网上很多使用wp建站的系统 此问题在最新版本WordPress 6.9.1依旧存在,具体表现为 无需登陆情况下 访问:域名/wp-json/wp/v2/users 可列出网站… -
windows host新增bat脚本
有些时候教用户本地修改host,遇到权限不足的问题,让他改权限跟下载编辑器都十分麻烦, 于是这个脚本诞生了,方便新增host指向 复制并保存为 changehost.bat 用管理员权限打开即可 @echo off chcp 65001 >nul setlocal enabledelayedexpansion REM Check for administrator privileges &g… -
PHP 算出字符串中文个数
算出某个字符串中中文的个数 $str = "中文english"; echo strlen($str); echo "<br>"; echo mb_strlen($str, "utf8"); 上面代码运行结果为 13 9 大家都知道,一个中文所占的字节数为 2,一个字母占 1 所以如果字符串中无中文时,这两个函数所求得出的字符… -
linux命令详解(19)修改文件属性lsattr、chattr命令详解
修改文件属性Linux文件系统里的文件和目录全都关联用户、用户组和其他用户的读、写和执行权限。此外,还可能存在其他特定文件系统类型才有的文件和目录相关属性。ext2和ext3文件系统文件可以选用一些特殊属性。使用lsattr命令可以列出这些属性。大部分属性都晦涩难懂,默认并不启用。下面的示例使用lsattr查看部分文件属性:?1234567891011# lsattr /etc/host* ---… -
阿里云短信API快速接入
针对某些情况 composer 无法使用或者只想接入阿里云短信服务的 某些项目无法使用 composer,比如只是想加一个阿里云短信,阿里云文档现在好像只支持 composer 方式了 Github项目地址:https://github.com/difuer-yl/alisms 直接上代码 /** * *$phon 电话号码 *$AccessKeyId 密钥 *$accessKeySecret 密… -
定时任务不切换用户执行的后果
事故背景 某 thinkphp6.x 项目运行时,偶尔出现异步队列执行失败的情况,实际调试时发现一切正常,但是异步队列就是会经常出现失败超时 调试来调试去,就是没有问题,怀疑执行的进程太多,抢占了任务??【为了加快速度,开了五个进程】,后面调试减少到一个进程,好像好了很多【心理安慰+999】 就这样相安无事了好几天,这个问题又出现!!! 再因为这个任务是支付确认的异步队列,要是订单没有办法确认的话… -
win10 Docker Desktop 启动失败 Failed to set version to docker-desktop: exit code: -1
今天 Docker Desktop 启动失败,搜到一篇文章完美解决 在Windows 10 的 2004 版本 中, 启用 使用Docker Desktop 时 发现 根本无法启动, 偶尔 或者频繁的出错: System.InvalidOperationException: Failed to set version to docker-desktop: exit code: -1 … -
数据库的用户表性别需要建立索引吗
今天朋友问我说,今天去面试的时候面试官问他,用户表的性别需要创建索引吗? (tinyint) 他的回答是看情况,可加可不加 而面试官期望的回答应该是不加,并且解析是根据笛卡尔积理论巴拉巴拉。。。 简单的说吧,一般不需要,因为性别,暂且就两个值男与女。一般而言男与女比例是平衡的。 索引的选择性是指索引列中不同值的数目和表的记录数的比值,假如表里面有1000条数据,表索引列有980个不同的值,这时候… -
vue页面部署后,刷新页面404
vue页面部署后,刷新页面404,多半跟代码无关,是nginx配置问题 如我的访问入口是 merchant nginx 的配置应该是 location /merchant/ { try_files $uri $uri/ /merchant/index.html; } 这个 Nginx 配置的作用是处理对 /merchant/ 路径的请求。具体来说,它的功能如下: try_files 指令:这个指令…


















