Window10 使用 Vue Yarn 使用时报错

根据官网 https://classic.yarnpkg.com/en/docs/install#windows-stable  安装说明使用npm安装 yarn

npm install --global yarn

执行成功之后window10 使用yarn  命令时报错

出现了以下错误

yarn : 无法加载文件

F:\nodejs\node_global\vue.ps1

,因为在此系统上禁止运行脚本。有关详细信息,请参阅 https:/
go.microsoft.com/fwlink/?LinkID=135170 中的 about_Execution_Policies。
所在位置 行:1 字符: 1
+ yarn
+ ~~~~
+ CategoryInfo : SecurityError: (:) [],PSSecurityException
+ FullyQualifiedErrorId : UnauthorizedAccess

PowerShell的执行政策阻止了该操作。
用 Get-ExecutionPolicy 查看发现执行策略为受限状态:

2.此时我们按照要求输入 Set-ExecutionPolicy -Scope CurrentUser  命令,回车,在黑窗口中输入RemoteSigned解除受限状态,回车

3.接下来我们查看受限状态 输入 get-ExecutionPolicy,此时结果为RemoteSigned(受限移除),这样我们就可以正常创建了

 

为TA充电
共{{data.count}}人
人已赞赏
知道工作日志随笔

win10 修改文件提示拒绝访问如何解决?

2021-5-3 23:45:02

知道工作日志资源分享

Postman 中文汉化

2021-5-13 11:46:52

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧